
pro Fit – a guided tour

pro Fit  
A Guided Tour

This is a quick introduction to pro Fit It 
gives a step by step description of a 
simple session with pro Fit and shows 
you some of the application's features.
Installation
Simply “unstuff” the pro Fit demo package (if you have not already done so) by 
double clicking it (or dragging it on a copy of StuffIt Expander™). Drag the resulting
folder to a suitable place on your hard disk.

A first session
In the following we describe a 
typical session with pro Fit. We 
plot and analyse the growth of the 
world’s population over the last 50 
years. The table to the right shows the 
number of inhabitants on this planet in 
the years since 1940.

year population in millions
1940 2200
1950 2500
1960 3000
1969 3600
1975 4000
1981 4400
1987 5000
1990 5300

To enter this data, you have to open a new data window:
• Choose “New Data” from the File menu.
An empty data window appears.
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The data is arranged in horizontal rows and vertical columns. The 
topmost cell of each column shows the name of the column (by default 
“Column 1”, “Column 2”, etc.). The cells below contain the data of each 
column.
Now you must enter the data into this window:
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• Click on the first empty cell of column 1 and enter the first 
year, 1940.

We fill the first column with the years and the second column with the 
population in millions. The first year is 1940.
• Click on the first cell of column 2 and enter the population, 

2200.
Note that we enter the population in millions.
• Repeat steps 2 and 3 to enter the remaining data in the 

following rows.
Fill in the year and population data as given in the table above. Note 
that you can use the arrow keys, the tabulator key, and the return and 
enter keys to move from one cell to another.
• Enter the column titles, ‘year’ and ‘population in millions’.
Click the column titles ‘Column 1’ or ‘Column 2’ and enter the new 
names. Your window should now look as follows:

Now that you have entered the data, you can display it graphically:
• Choose “Plot Data...” from the Draw menu.
The following dialog box appears.
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In this dialog box you can enter the range of the plot, the columns to be 
plotted and some other options. In this introductory session we can use 
the settings as they are.
• Click OK.
A drawing window appears, showing a graph of the data.
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Now you can edit this graph by using some of pro Fit’s drawing features.

• Double-click the vertical axis to change its range.
(Double-click the vertical axis itself, not the numbers to the left of it!) A dialog box appears, presenting some options for the axis. 

You can change a variety of options here. Most often you will use the 
edit fields “Min” and “Max”. They define the range of the axis. Another 
important field is the “Distance” field that defines the distance between 
major ticks.
• Enter 0 for “Min” and 6000 for “Max”, then click OK.
The vertical axis of the graph starts now with 0 and ends with 6000.
Double-click other parts of the graph or its legend to see other dialog 
boxes, where you can change more attributes. Try double-clicking the 
horizontal axis, the centre of the plot, or the dot in the legend. You can 
also double-click any text in the drawing to change it. Or you can 
choose any of the drawing tools at the left border of the window to add 
lines, polygons, text, etc.
Fitting a function to our data
The growth of a population can often be described by an exponential 
function of the type
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p(t) =p(x0 )× exp

t−x0
t0

 ⎛
 ⎝ ⎜

 ⎞
 ⎠ ⎟ ,(1)

where p(t ) is the population at time t, p(x0) the population at an arbitrary start time x0, 
and t0 its growth constant.
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Let us try to investigate the validity of this formula for the world's population. We want to find the set of 
parameters for equation (1) that describes our data best. 

• Choose “exp” from the Func menu.
The Parameters-window comes to the front. This window gives a description of the built-in exponential function 
and its parameters.

The function looks like this:

  
y =A ×exp

x −x0
t0

⎛ 

⎛ 
⎛ 

⎛ 

⎛ 
⎛ + const , (2)

This formula is substantially identical to Eq. (1).
The Parameters-window displays the default values for A, x0, t0, and const. 
Starting from these values, pro Fit will look for a better set of parameters for describing the data. But first you must define which 
parameters you want to fit (i.e. to vary) and choose good starting values.
As mentioned above, the starting time x0 is arbitrary. Let us set it to 1940:

• Click the number beside “x0” in the Parameters-window and enter the starting value 1940.
This defines the parameter's value.
Since x0 is arbitrary, we do not want to fit it:

• Uncheck “Use for fitting”.
(The check box “Use for fitting” can be found in the lower right area of the window.) The parameter name 
changes from bold face to plain text. This indicates that this parameter is constant and will not be fitted.
Shortcut: You can also toggle the option “Use for fitting” by simply clicking on a parameter’s name.
We also hold the constant const fixed at 0, since we don’t need it:

• Click the parameter name “const”.
Again, the text changes from bold to normal and the option “Use for fitting” is unchecked to indicate that the 
corresponding parameter will not be fitted.
Before fitting, you should assign starting values (guesses) to the parameters that are going to be fitted, in our 
case A and t0. This makes the calculations faster and improves the chances to find the best set of parameters. 
Reasonable starting values for our problem can be estimated easily:
A is the population in the year 1940, so we can set it to 2200 millions. –t0 (note the minus, it comes from the 
different definitions of Equations (1) and (2)) is the time in which the population increases by a factor e = 2.71. 
Looking at the plot of the data in the drawing window, we can easily guess it to be between 50 and 200 years. 
Let us set t0 to –100 (the minus sign comes from the differing definitions of Eqs. (1) and (2)):

• Enter the starting values 2200 for A and –100 for t0.
The resulting parameters-window should now look like this:
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Now we are ready to fit our parameters, but before doing so, let us look 
at another useful feature of pro Fit, the “Preview window”.
Intermission: Previewing the data and the function
To see the Preview window, choose Preview from the Windows menu:

To the left of the window there are some controls that let you determine
what the window must show, and if it must be a floating window or a 
normal window. To the right are some tools that can be used to edit and 
analyze the function and the data.
The window shows the current data set and the current function. If you 
change any function parameter, the curve will change to reflect the new
value. The window always shows a plot corresponding to the current 
function and data points. 
As you see, our first guess for the function parameters was not 
altogether bad, but the function doesn’t grow as fast as the actual data. 
To get the best parameters, let’s go back to fitting:
• Choose “Nonlinear Fit” from the Calc menu.
You see a dialog box where you can choose the data to fit:
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• Click OK to start fitting
Fitting should not take more than a few seconds. The fitted parameters 
are printed in the Results-window.
The fit yields –54 years for t0 and 2113 millions for  parameter A.
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To see the a graphical result of the fit, have a look at the Preview window:

Now we can plot the fitted function in the drawing window:
• Choose “Plot Function...” from the Draw menu
A dialog box appears, displaying some plotting options:

• Click OK to draw the curve.

This sample session could only show some few aspects of pro Fit’s drawing and 
fitting capabilities. As you start working with pro Fit, you will find many features that have not been mentioned here. They are easy to 
understand, and you will be able to use most of them without further explanations.
The following chapters will give you a short summary of some of the more unusual features of the application.

The preview window
The preview window provides a unique, interactive tool for editing and viewing 
functions and data.

The tools on its right side provide the following features:
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• Arrow tool: selecting or changing data. To change 
data, first select the desired data, then click and drag it.
• Hand tool: moving the area to be viewed
• Lens tool: zooming in and out (to zoom out, hold 
down the shift key)
• Fitting tool: changing parameters. Simply click on 
a function’s curve and drag it to vary a parameter. (Note:
The fitting tool is disabled when you have checked 
“Fitted params” in the Preview window.)
• Marker tool: placing markers on data and 
functions

arrow tool

hand tool

lens tool

fitting tool

marker tool
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Defining your own functions
In the above session you fitted the built-in exponential function to your data set.  
However, what do you do if your model function is some lengthy, complicated 
mathematical construction that does not appear among pro Fit’s built-in functions in the “Func” 
menu?
Define your own function! In pro Fit you can define virtually any function using a Pascal-like syntax. Let’s look at an example:
Imagine you want to analyse a function of the form

y  =  a1 sin(x) × ln(x)  + a2 (3)

with the parameters a1 and a2. To define it in pro Fit:

• Choose “New Function” from the File menu.
This opens a new, empty function window.

• Enter the function in the new window.
Enter the following text:

a[1]*sin(x)*ln(x) + a[2]

• Click the "Add" button in the top left corner of the function window, or choose “Add To Menu” from the Misc menu.
The new function is added to the Func menu, and the parameter window shows its default parameters a[1], a[2]. At the same time pro Fit converts your function into a 
full Pascal definition:

function User_Function;
begin

y := a[1]*sin(x)*ln(x) + a[2];
end;

To view your function, you first should set its parameters a[1] and a[2] to reasonable values, e.g. 1 and 0.5: Edit the fields of the parameter-window. Then bring the 
Preview window to front and check “Show function”. Alternatively, you can choose “Plot Function...” from the Draw menu for creating a plot of your function in the 
drawing window. (If you still have an open drawing-window from previous work, you should check the option “Open New Window” in the dialog box, or your curve will 
be drawn in the old graph.)

Our sample function is not defined for x<=0. If you would calculate it for a negative x-value, pro Fit would report an error. However, the function converges to
y=a[2] for x=0. 
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You may want to expand its definition range by defining y(x) = a[2] for all negative or zero x. This can be done easily by the following modified 
definition:

function User_Function;
begin

if x <= 0
 then y := a[2]
 else y := a[1]*sin(x)*ln(x) + a[2];

end;

(After having modified the definition in the Function-window, again choose “Add to Menu” from the Misc menu to add the modified function to pro Fit.)
This new version of the function shows how you can use the if statement for conditional execution.
Your function can even be much more complicated than that. pro Fit allows function definitions that contain more than one statement. You also 
can define your own variables and procedures, you can access the data in the data windows, and much more. You can use most elements of the 
“Pascal” programming language.
In your demo package you can find various examples of function definitions.

Writing programs
Besides defining functions for fitting and plotting, you can also define any algorithm 
for data-generation and -transformation.
Let us have a quick look at a small program that fills the first column of a data 
window with the powers of two:  2, 4, 8, 16, etc. To define this program, again open 
a new Function-window (“New Function” from the file menu) and enter the 
following definition. (Note that this program starts with the keyword program, and 
not function. The rest of it follows the same syntax scheme as a function 
definition.)

program PowersOf2;
var i: integer;
begin
 NewWindow(dataType);
 for i := 1 to nrRows do
    data[i,1] := 2 ** i;

SetColumnName(1,'Powers');
end;

To add this program to pro Fit, again choose “Add to Menu” from the Misc menu. The program “PowersOf2” is appended to the “Misc” menu. To 
start it, choose it from this menu.
There is much more that you can do with functions and programs in pro Fit. You can e. g. draw from a program, you can integrate functions or 
find their roots, you can access fitting results, open and close files, etc.
For a complete list of syntax elements for writing functions and programs, you can consult pro Fit’s on-line programming help. Click on the 
question mark at the top of the function window or choose “pro Fit Programming” from the Apple Guide menu. There is also a pop-up menu 
titled “Help” that brings up a list of all built-in functions and procedures.
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Getting help     
pro Fit provides a powerful on-line help system based on Apple Guide. To use it, you 
must have installed Apple Guide on your system. Apple Guide is a standard 
extension on System 7.5 or later but can also be installed on earlier systems.
To invoke the on-line help, choose “pro Fit Guide” from the Apple Guide menu (click 
the question mark in your menu bar). You can also invoke the help system from most
dialog boxes and windows by clicking the question mark icon – this takes you 
directly to a panel that describes the corresponding window/dialog box.

Some hints

Printing
pro Fit was designed for optimum quality results on every printer. For high-end laser writers PostScript® commands can be 
generated.  For all other printers (such as high-resolution ink-jet printers), printing occurs at maximum available
resolution.
Therefore, to get best results, you should tell pro Fit if you are using a PostScript printer or not. To do this, choose “Preferences...”
from the File menu. In the dialog box that appears, click the icon “Printing”. In the corresponding panel,  you should check or uncheck the 
check-box “Print drawings using PostScript”.
If you have installed System 7.5 and Quickdraw GX, you can alternatively select the option “Use Quickdraw GX”. This tells pro Fit to use the 
new, powerful printing mechanisms of Quickdraw GX.

Exporting pictures
When you are working with a drawing application such as pro Fit, you may want to copy drawings from this application into your word-
processor.
There are three possibilities to do that:
1. Copy the desired part of a drawing from pro Fit and paste it into your word processor.
2. Create a publisher and subscribe to it from your word processor (if your word processor supports this feature).
3. If you are going to print on a PostScript printer, you can save your drawing as a PostScript- (EPS) file (if your text application supports this 

feature).

With many conventional applications, drawings copied by method 1 or 2 may print in poor quality on some printers. With pro Fit you can export 
pictures that print fine in most situations!
In order to take advantage of this feature, you should tell pro Fit what kind of printer you are going to use. If you are using a PostScript printer, 
pro Fit can include PostScript information in its pictures, if you are using a non-PostScript printer, pro Fit can generate so called “high-
resolution bitmaps” that print fine on most printers.
To set the desired option, choose “Preferences...” from the File menu and click the icon “PICT Options”. Then you can specify if you want 
PostScript to be included in the pictures that you copy from pro Fit (check “Embedded PostScript”), or if you want a bitmap (check “Bitmap” and
enter your printer’s resolution). If you are using Quickdraw GX, choose “Normal PICT” and check “Add Quickdraw GX” – this generates pictures 
that will print fine on all printers.
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More highlights 

Graphic text editor:
Have you already edited a text in the Drawing-window? If not, then 
open a drawing window, select the text tool (the “A” in the toolbox at the
left border of the window), and click into the drawing window. In the 
dialog box that comes up, you can interactively create any text, with any
font, size, and style, with arbitrary sub- and superscripts.
External modules:
If you should ever think that you have reached the limits of pro Fit:
You may have noticed the command “Load Modules...” in the Misc menu. 
With this command, you can add the code of a function or program that you have written in any compiler of yours, and use it in the same way as 
any built-in function or program.
If you are used to programming your own code for data or function analysis, you can consider pro Fit as a big library offering routines for 
numeric analysis, data input/output and high resolution graphics output.
The pro Fit demo package includes some code and source examples of external functions and programs in the folder “External Modules”.

Contour plotting, 3D-plotting, histograms, polar plots, etc.
pro Fit comes with external modules for 3D-plotting, contour plotting, histograms, pie charts, polar plots, vector plots and more. To use these 
modules, you must link them to pro Fit: Choose “Load Module...” from the Misc menu and select the desired module. It is added to the Misc 
menu. (Note: The 3D-plotting modules are available for Power Macintosh only and require Quickdraw 3D.)

And more...:
As you work with pro Fit, you will discover many other unique features. Have a look at the files that come with the demo package. Explore!
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pro Fit
Projecting the best image of your data
This demo version of pro Fit supports all the features of the commercially available 
full version of pro Fit 5.0 except saving files.

The full pro Fit comes with a comprehensive user manual.  This includes a tutorial, 
and detailed chapters on editing and transforming data, working with functions and 
programs, drawing and curve fitting.  You can order a full version of pro Fit for 
evaluation on our risk-free 30-day money-back guarantee.

If you have any technical questions about pro Fit, ring Cherwell at any of the 
numbers below.  Our support team are ready to help you before and after you buy.
Don’t you wish you were using pro Fit today? Telephone, fax, or send your order direct to Cherwell Scientific at one of the 
following addresses.  
Or you can order pro Fit from your local dealer.

Cherwell Scientific Publishing Ltd Cherwell Scientific Publishing Inc
The Magdalen Centre 744 San Antonio Road, Suite 27A
Oxford Science Park Palo Alto, CA 94303
Oxford OX4 4GA USA
United Kingdom

Tel: +44 (0)1865 784800 Tel: (415) 852 0720
Fax: +44 (0)1865 784801 Fax: (415) 852 0723
e-mail: csp@cherwell.com e-mail: csp.usa@cherwell.com

Cherwell Scientific Publishing Ltd. 
c/o CHEM Research GmbH 
Hamburger Allee 26-28
60486 Frankfurt 
Germany 

Tel: +49 (0)69 970841-11 
Fax: +49 (0)69 970841-41
e-mail: csp.d@cherwell.com 

http://www.cherwell.com/cherwell/
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